Jump to content
  • 0

Adguard Home


Go to solution Solved by Perks,

Question

Boas. Preciso de mais uma ajuda dos entendidos

 

Então é assim, resolvi voltar a testar o adguard Home e estou a gostar face ao pihole. Eu tinha testado há tempos e tive uns stress, mas como vou ficar uma dias em casa se calhar poderei ir testando melhor

Instalei e está tudo a funcionar como deveria, excepto um pequeno pormenor

Quero alterar os nomes da minha rede local. Basicamente quero adguard.lan a apontar para esta rpi, o hass.lanv para o home assistant, etc tenho uns 20 IP fixos em casa, era importante conseguir isso

 

A questão é que faço isso no rewrite e Isto não detecta.

Alguém que use isto que me consiga dar uma ajuda?

@Nazgulledjulgo

Link to post
Share on other sites

14 answers to this question

Recommended Posts

  • 0

Ainda bem que já resolveste, mas estou confuso com a tua resolução...

Como é que estavas inicialmente a atribuir o IP da máquina que tens o AdGuard Home a correr, aos clientes da tua rede? Devia bastar isso e os rewrites deviam simplesmente funcionar. Eu faço push dos servidores DNS através do servidor DHCP do router, se conseguires fazer isto, IMO é a melhor forma em vez de complicar com regras na firewall.

Já agora, pessoalmente não uso os rewrites porque por vezes quero desligar a protecção (para testar coisas e assim) e isso desliga os rewrites também (há uma issue aberta para resolverem isso, mas até hoje, nada). Por agora tenho o dnsmasq a correr no router que é onde defino as regras nome=IP, e depois tenho uma excepção no AdGuard para todos os pedidos que forem de um determinado dominio serem direcionados para o DNS no router (o dnsmasq). É um bocado confuso e preferia não ter isto assim, mas enquanto não resolverem a respectiva issue, assim fica.

Link to post
Share on other sites
  • 0
1 hour ago, Nazgulled said:

Eu faço push dos servidores DNS através do servidor DHCP do router, se conseguires fazer isto, IMO é a melhor forma em vez de complicar com regras na firewall.

não quero fazer isso

Eu tenho definido uma regra no router que me faz ping à rpi com o AdGuard a cada minuto. Se estiver down simplesmente muda os servidores DNS da rpi para os servidor AdGuard.

 

 

 

Se fizer push via DHCP (que posso fazê-lo) como é que vou dizer às máquina que têm de renovar?

 

 

 

 

1 hour ago, Nazgulled said:

Devia bastar isso e os rewrites deviam simplesmente funcionar.

não fazia, o Mikrotik penso que tem um stress qualquer com hostnames, já li qualquer coisa. O @skaazi até me enviou um script para fazer isso, mas não deveria ser necessário isso, mas não sei porquê não funcionava

Link to post
Share on other sites
  • 0
1 hour ago, Perks said:

Se fizer push via DHCP (que posso fazê-lo) como é que vou dizer às máquina que têm de renovar?

Renovar o quê?

 

48 minutes ago, Ovelha said:

Voces não querem fazer aí uns serviços para configurações de redes domésticas?

Não tens orçamento para os meus serviços :-..

Link to post
Share on other sites
  • 0
1 minute ago, Nazgulled said:

Renovar o quê?

se fazes push dos servidores DNS no DHCP, e dás um lease de 24 horas por exemplo

Se às 12H o teu adguard cair, como é que o cliente vai saber que aquele endereço do DNS não está válido?

Link to post
Share on other sites
  • 0

ok, já percebi como resolver neste caso, faço push do próprio router como servidor DNS e dinamicamente altero os servidores

 

Mas agora surgiu outra questão. A rpi pode estar a responder ao ping, mas pode o AdGuard não estar a funcionar, pelo que neste caso terá de ser com script

faço um check à página de controla da API deles

http://[IP Adguard]/control/status

:local servers [/ip dns get servers];
:do {
    /tool fetch url="http://192.168.0.20/control/status";
    if ($servers != "192.168.0.20") do={
        /ip dns set servers=192.168.0.20;
    }
} on-error {
    if ($servers != "94.140.14.14;94.140.15.15") do={
        /ip dns set servers=94.140.14.14,94.140.15.15;
        :log error "AdGuard-Home não está a funcionar, a usar AdGuard DNS";
    }
}

 

Faz sentido ou vou fazer bosta?

Link to post
Share on other sites
  • 0
1 hour ago, Perks said:

se fazes push dos servidores DNS no DHCP, e dás um lease de 24 horas por exemplo

Se às 12H o teu adguard cair, como é que o cliente vai saber que aquele endereço do DNS não está válido?

O meu AdGuard não cai, não é um problema para mim.

Acho que estás a resolver um não-problema, ou então a resolve-lo pelo lado errado. Eu também tenho um RPi com o AdGuard Home lá dentro (entre outras coisas), a correr em Docker (não sei se é o teu caso), e não tenho qualquer preocupação com o serviço do AdGuard cair, nem nunca tive. Está sempre a funcionar, 24/7. Se tens problemas do serviço cair ao ponto de estares a implementar essas redundâncias todas, se calhar devias tentar o corrigir o problema principal, e não colocar remendos :P

Link to post
Share on other sites
  • 0

está com o snaps numa rpi e também não cai julgo eu

 

Mas lá está, gosto de deixar estas coisas automatizadas para não haver stress

Não me apetece um dia estar fora de casa ter ido a luz abaixo ou assim e estar sem serviço porque não acautelei 😛 

Link to post
Share on other sites
  • 0

Bem, como sou teimoso lá fui eu fazer isto, tive de fazer umas alterações no script que pensei incialmente, porque a rest API do Adguard exige autenticação, anyway se te interessar fica aqui, não sei se no Ubiquiti é semelhante ou não, mas fica aqui

Isto checa se o Adguard-home está activo e caso não esteja simplesmente altera os DNS para os da Adguard

No DHCP faço o push do IP do router como DNS

:local servers [/ip dns get servers];
:do {
    /tool fetch http-header-field="Authorization: Basic user:password" url="http://IP_Adguard/control/status" keep-result=no;
    if ($servers != "IP_Adguard") do={
        /ip dns set servers=IP_Adguard;
    }
} on-error {
    if ($servers != "94.140.14.14;94.140.15.15") do={
        /ip dns set servers=94.140.14.14,94.140.15.15;
        :log error "AdGuard-Home não está a funcionar, a usar AdGuard DNS";
    }
}

onde tem o user:password tem de ser neste formato em BASE64 Encoded

onde tem o IP_Adguard é substituir pelo IP 

Link to post
Share on other sites
  • 0

Eu não gosto de configurar dessa forma por dois motivos:

  • Continuo a não achar que faz sentido meter regras de firewall ao barulho para este caso, não me parece ser a forma correcta de resolver o problema (claro que se houver bugs/dificuldades no sistema que se usa, compreendo)
  • Se todos os clientes têm no DNS o IP do router, o AdGuard não tem forma de identificar os clientes individuais e não podes ter configurações individuais por cliente
  • Evito usar scripts, quantos menos tiver melhor, são demasiadas peças de configuração que torna as coisas mais complexas e manter isso dá trabalho
2 hours ago, Perks said:

está com o snaps numa rpi e também não cai julgo eu

 

Mas lá está, gosto de deixar estas coisas automatizadas para não haver stress

Não me apetece um dia estar fora de casa ter ido a luz abaixo ou assim e estar sem serviço porque não acautelei 😛 

Posso estar a perceber algo mal aqui, mas se a luz for abaixo, não tens nenhum equipamento ligado, o script não vai executar :-..

Mas lá está, se falas de a luz ir abaixo e voltar, e depois teres a garantia que os serviços funcionam, a solução correcta, para mim, é garantir que as máquinas inicializam sempre todos os serviços correctamente, independentemente das circunstâncias que as fez ir abaixo.

Mas pronto, whatever works for you :)

Link to post
Share on other sites
  • 0

Se calhar tens razão, mas eu gosto mesmo de ter soluções em caso de falhas nestas coisas, se calhar sou um chato, mas faço sempre isto. 

Tenho 2 miúdos em casa e muita experiência para perceber que para eles desligar uma rpi da corrente por exemplo não era nada demais :-.. ou até a senhora que vem cá fazer limpeza tirar alguma coisa

eu podia alterar o script para ao invês de alterar o DNS fazer um push do DHCP, mas lá está se os clientes tiverem umas horas pela frente até o lease chegar a metade, são horas que não têm net

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.